summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44412eddc019
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor: Marti Raudsepp <marti@juffo.org>
+pkgname=seekwatcher-hg
+pkgver=104
+pkgrel=1
+pkgdesc="Generates graphs from blktrace runs to help visualize IO patterns and performance"
+arch=(i686 x86_64)
+url="http://oss.oracle.com/~mason/seekwatcher/"
+license=('GPL')
+makedepends=('mercurial' 'python')
+depends=('python-matplotlib' 'python-numpy')
+optdepends=('blktrace: for tracing the local system')
+conflicts=('seekwatcher')
+md5sums=()
+
+_hgroot="http://oss.oracle.com/mercurial/mason/"
+_hgrepo="seekwatcher"
+
+build() {
+ cd $srcdir
+
+ if [ -d $_hgrepo/.hg ]; then
+ (cd $_hgrepo && hg up -r $pkgver)
+ else
+ hg clone -r $pkgver $_hgroot/$_hgrepo $_hgrepo
+ fi
+
+ msg "Mercurial checkout done or server timeout"
+
+ if [ -d $_hgrepo-build ]; then
+ msg "Removing old build directory"
+ rm -rf $_hgrepo-build
+ fi
+
+ msg "Copying repository to another build directory"
+ cp -r $srcdir/$_hgrepo $srcdir/$_hgrepo-build
+
+ msg "Starting build"
+ cd $srcdir/$_hgrepo-build
+
+ msg "Running setup.py"
+ python setup.py build || return 1
+ python setup.py install --root=$pkgdir || return 1
+
+ msg "Installing documentation"
+ install -dm 755 $pkgdir/usr/share/doc/seekwatcher
+ cp -r $srcdir/$_hgrepo-build/README.html $pkgdir/usr/share/doc/seekwatcher
+}
+