summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bca4af447a79..a3b1d1b464bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=seiscomp-maps
-pkgver=4.8.2
+pkgver=20220113
pkgrel=1
pkgdesc="SeisComp map files."
arch=('any')
@@ -11,12 +11,13 @@ install=${pkgname}.install
source=("${url}/downloader/${pkgname}.tar.gz"
"${pkgname}-tmpfiles.conf")
sha256sums=('e0488c4905260ab160b7ee2508ad5b70467665632b8f15428864cccb444e4cca'
- 'd322747672e4261c5aad058391b5c9d3e6dde34c05133edb9a9ef5c67aead1de')
+ '312911098291e60a40d4f3fd455b9a40b2d9b3489a589fb927fb6fc0b9ac2dd2')
package() {
install -d "${pkgdir}/opt"
cp -r "${pkgname%-maps}" "${pkgdir}/opt/"
install -D -m 644 "${pkgname}-tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
- chmod -R g+w "${pkgdir}/opt/${pkgname%-maps}/share/maps"
+ chmod -R u=rwX,g=rwX,o=rX "${pkgdir}/opt/${pkgname%-maps}"
+ find "${pkgdir}/opt/${pkgname%-maps}" -type d -exec chmod g+s '{}' \;
}
# vim:set ts=4 sw=4 et: