summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5381ab16ea3..d22bba319caa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=selfoss
pkgver=2.14
-pkgrel=1
+pkgrel=2
pkgdesc="The new multipurpose rss reader, live stream, mashup, aggregation web application"
arch=('any')
url="http://selfoss.aditu.de/"
@@ -24,6 +24,14 @@ install=${pkgname}.install
source=("https://github.com/SSilence/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.zip")
sha256sums=('23ddf9de2d5192133701576d66e45e1509b468160236e600b80d86737c1052e9')
+prepare() {
+ cd "${srcdir}/libs"
+
+ # Fix bug with update on php7
+ sed -i 's/function floIconImage/function __construct/' floIcon.php
+ sed -i 's/function floIcon/function __construct/' floIcon.php
+}
+
package() {
rm -rf "${srcdir}"/{README.md,${pkgname}-${pkgver}.zip}