summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51af1504636f..3d8346e1ddfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=selfspy-git
_pkgname=${pkgname%-git}
pkgver=0.1.4.r202.ga98a9c0
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="X11 personal keylogger daemon with statistical analysis."
url="https://github.com/gurgeh/selfspy"
@@ -19,14 +19,16 @@ depends=('python2-daemon'
'python2-xlib'
'python2-sqlalchemy'
'tk'
- 'python2-crypto')
+ 'python2-pycryptodome')
makedepends=('git')
source=("$_pkgname"::"git+https://github.com/gurgeh/$_pkgname.git"
"$_pkgname.conf"
- "$_pkgname@.service")
+ "$_pkgname@.service"
+ 'pycryptodome.patch')
md5sums=('SKIP'
'c19d0212e7c6c1fe90c6975da9937db2'
- '2874c55b09f87c946824dfdf4f60e1ed')
+ '2874c55b09f87c946824dfdf4f60e1ed'
+ 'SKIP')
pkgver() {
cd $_pkgname
@@ -37,6 +39,9 @@ prepare() {
cd $_pkgname
sed -i 's/env python/env python2/g' $_pkgname/__init__.py
sed -i 's:var/lib:usr/share:g' Makefile
+ sed -i 's/pycrypto>=.\+/pycryptodome>=3.6.6/g' requirements.txt
+ # Apply hacks to keep it working with pycryptodome
+ patch -p1 < "$srcdir/pycryptodome.patch"
}
package() {