summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 271074fcbe57..77f8c519c864 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Pierre Carrier <pierre@gcarrier.fr>
pkgname=sensible-utils
-pkgver=0.0.9
+pkgver=0.0.12
pkgrel=1
pkgdesc="Utilities for sensible alternative selection"
arch=('any')
@@ -8,22 +8,26 @@ url="http://packages.debian.org/source/sid/sensible-utils"
license=('GPL')
depends=('bash')
makedepends=('po4a')
-source=(http://ftp.de.debian.org/debian/pool/main/s/$pkgname/${pkgname}_$pkgver.tar.gz)
-md5sums=('559012932ffa95a7bbd8f8423869b652')
+source=(http://ftp.de.debian.org/debian/pool/main/s/$pkgname/${pkgname}_$pkgver.tar.xz)
+sha256sums=('99ba2ebf8c57447c69d426b99b84ff9dc817be0bc4988ec6890a14558c529e2e')
build() {
- cd $pkgname-$pkgver
+ cd $pkgname.git
+ export -n EDITOR VISUAL
./configure --prefix=/usr
make
}
check() {
- cd $pkgname-$pkgver
+ cd $pkgname.git
+# need --nocheck for makechrootpkg inpite of this
+ export -n EDITOR VISUAL
make -k check
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname.git
+ export -n EDITOR VISUAL
make DESTDIR="$pkgdir/" install
}