summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cb61c1a1528
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: L. Bradley LaBoon <me@bradleylaboon.com>
+pkgname=sentinl
+basever=6.6
+pkgver=${basever}.1
+pkgrel=1
+pkgdesc="Siren Platform + Kibana Alert & Report App for Elasticsearch"
+url="https://github.com/sirensolutions/sentinl"
+arch=('any')
+license=('Apache')
+depends=("kibana=$pkgver")
+source=("https://github.com/sirensolutions/sentinl/releases/download/tag-${basever}.0-0/sentinl-v${pkgver}.zip")
+sha256sums=('9d226cf0c63f290474f723a3e922f2119a3f3ee2af3488b02e6f9954b20b00f8')
+
+package() {
+ cd "$srcdir"
+ install -dm 0755 "$pkgdir/usr/share/kibana/plugins"
+ cp -r "$srcdir/kibana/$pkgname" "$pkgdir/usr/share/kibana/plugins"
+}