summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 997afe004e2a..9b82cefc627e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
pkgname=sepolgen
-pkgver=1.2.1
-pkgrel=2
+pkgver=1.2.2
+pkgrel=1
pkgdesc="SELinux policy generator"
groups=('selinux')
arch=('any')
@@ -14,20 +14,15 @@ license=('GPL')
depends=('python2')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20140506/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('438c246bdc6b3cf1b12116831f4c601aaae6e93decb007dddab212a3c88781b0')
-
-prepare() {
- cd ${pkgname}-${pkgver}
- sed -i -e "s/ python/ python2/" src/sepolgen/Makefile
-}
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20150202/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('bebda8eeb2d386d26823d724ea320508a02b50828d44aff47c3f907cf54c2324')
build() {
- cd ${pkgname}-${pkgver}
- make
+ cd "${pkgname}-${pkgver}"
+ make PYTHON=python2
}
package(){
- cd ${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
+ cd "${pkgname}-${pkgver}"
+ make PYTHON=python2 DESTDIR="${pkgdir}" install
}