summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15850cb6b13b..43fd38757cda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
+# Maintainer: quomoow <quomoow@gmail.com>
# Contributor: Sean Bartell <archlinux@yotann.org>
-pkgname=seq24-bzr
-pkgver=136
+
+pkgname=seq24
+pkgver=0.9.3
pkgrel=1
pkgdesc="A pattern-based midi sequencer with strong live performance functions"
arch=('i686' 'x86_64')
@@ -10,17 +12,20 @@ depends=('gtkmm>=2.4.0')
makedepends=('bzr')
provides=('seq24')
conflicts=('seq24')
-source="bzr+http://bazaar.launchpad.net/%7Eseq24team/seq24/trunk"
-md5sums=("SKIP")
+source=("bzr+http://bazaar.launchpad.net/~${pkgname}team/${pkgname}/trunk")
+md5sums=('SKIP')
build() {
cd trunk
+
autoreconf -i
+ CXXFLAGS="-O2 -std=c++11"
./configure --prefix=/usr --disable-lash
make
}
package() {
cd trunk
+
make DESTDIR="$pkgdir/" install
}