summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a0a7db06989
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Niclas Meyer <niclas at countingsort dot com>
+
+pkgname=sequestrum-git
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="Modern, feature-packed dotfile manager"
+arch=('any')
+url="https://github.com/iiPlasma/sequestrum"
+license=('MIT')
+depends=('python' 'python-pyaml')
+makedepends=('git')
+provides=('sequestrum')
+conflicts=('sequestrum')
+source=("$pkgname::git+https://github.com/iiPlasma/sequestrum")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --always | sed -e 's/-/_/g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py -q install --root="$pkgdir"
+}