summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 583d6d28b8c5..47d1cc2e7d7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Patrik Bachan <patrikbachan at gmail dot com>
pkgname=serialplot-hg
_pkgname=serialplot
-pkgver=796+.f5f0a29e6433+
+pkgver=794+.9d8cc029351b+
pkgrel=1
pkgdesc="Small and simple software for plotting data from serial port in realtime"
arch=('i686' 'x86_64')
@@ -11,11 +11,9 @@ depends=('qwt' 'qt5-base' 'qt5-serialport' 'hicolor-icon-theme')
makedepends=('mercurial' 'cmake')
provides=('serialplot')
conflicts=('serialplot')
-source=('hg+https://bitbucket.org/hyOzd/serialplot'
- 'cmake_qwt.patch'
+source=('hg+https://bitbucket.org/hyOzd/serialplot#branch=default'
'update_check_disable.patch')
sha256sums=('SKIP'
- 'b1508ee32f79c82ad6e1749ddc79c33e4af3e3178c0e8e67c9011eda040c8652'
'116736d9471b5e0d283c264c1df8db5e4eb5e927839db7eee0022ab7b9177961')
pkgver() {
@@ -26,12 +24,8 @@ pkgver() {
prepare() {
cd "$srcdir"
#disable update checking, otherwise app crashes
- #this is dirty fix
+ #this is dirty fix, just immediately returning from update function
patch --forward --strip=1 --input="${srcdir}/update_check_disable.patch"
- #patch qwt search script
- #https://bitbucket.org/hyOzd/serialplot/issues/15
- cd "$srcdir"
- patch --forward --strip=1 --input="${srcdir}/cmake_qwt.patch"
}
build() {