summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 3 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47d1cc2e7d7b..39b4b4b36715 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Patrik Bachan <patrikbachan at gmail dot com>
pkgname=serialplot-hg
_pkgname=serialplot
-pkgver=794+.9d8cc029351b+
+pkgver=811.5c9db4e54bbd
pkgrel=1
pkgdesc="Small and simple software for plotting data from serial port in realtime"
arch=('i686' 'x86_64')
@@ -11,23 +11,14 @@ depends=('qwt' 'qt5-base' 'qt5-serialport' 'hicolor-icon-theme')
makedepends=('mercurial' 'cmake')
provides=('serialplot')
conflicts=('serialplot')
-source=('hg+https://bitbucket.org/hyOzd/serialplot#branch=default'
- 'update_check_disable.patch')
-sha256sums=('SKIP'
- '116736d9471b5e0d283c264c1df8db5e4eb5e927839db7eee0022ab7b9177961')
+source=('hg+https://bitbucket.org/hyOzd/serialplot')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
echo $(hg identify -n).$(hg identify -i)
}
-prepare() {
- cd "$srcdir"
- #disable update checking, otherwise app crashes
- #this is dirty fix, just immediately returning from update function
- patch --forward --strip=1 --input="${srcdir}/update_check_disable.patch"
-}
-
build() {
cd "$srcdir/$_pkgname"
mkdir build