summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 5 insertions, 59 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4e7dd7bcf5e..34c48582791a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,16 +14,16 @@
# TODO: install man and app metadata
pkgbase=setroubleshoot-git
-pkgname=(setroubleshoot-git setroubleshoot-server-git)
+pkgname=setroubleshoot-git
pkgver=3.3.32.r3.g502d06c
-pkgrel=4
+pkgrel=5
pkgdesc="Provides tools to help diagnose SELinux problems"
groups=('selinux')
arch=('x86_64' 'aarch64')
url='https://gitlab.com/setroubleshoot'
license=('GPL2')
conflicts=("setroubleshoot")
-provides=("setroubleshoot-git" "setroubleshoot-server-git")
+provides=("setroubleshoot-git")
makedepends=('audit' 'dbus' 'desktop-file-utils' 'gtk3' 'libnotify' 'libreport'
'policycoreutils' 'polkit' 'python-gobject' 'python-pydbus'
@@ -31,15 +31,9 @@ makedepends=('audit' 'dbus' 'desktop-file-utils' 'gtk3' 'libnotify' 'libreport'
source=(
'setroubleshoot-git::git+https://gitlab.com/setroubleshoot/setroubleshoot#branch=main'
- 'setroubleshoot.logrotate'
- 'setroubleshoot.tmpfiles'
- 'setroubleshoot-sysusers.conf'
)
-sha256sums=('SKIP'
- '894a75c33d568f908f0c3fa7fe4d7f82824369695194aa005fe42cf961298893'
- 'eb7321b7db2fd8951c7ce3c7c42680fcfe7641c3d7be9e8d69a8fbb992a9d086'
- 'fa20d1ec3522aa877fc5462d56692b318b4c8af1cd9ecb62ec41ad6647662d77')
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
@@ -59,7 +53,7 @@ build() {
make
}
-package_setroubleshoot-git() {
+package() {
pkgdesc="Provides tools to help diagnose SELinux problems - GUI"
depends=('setroubleshoot-server-git' 'hicolor-icon-theme' 'python')
@@ -101,51 +95,3 @@ package_setroubleshoot-git() {
}
-package_setroubleshoot-server-git() {
- pkgdesc="SELinux troubleshoot server"
-
- cd "${pkgbase}"
- install -m644 -D "src/sedispatch.conf" "${pkgdir}/etc/audit/plugins.d/sedispatch.conf"
- install -m755 -D "src/sealert" "${pkgdir}/usr/bin/sealert"
- install -m644 -D "setroubleshootd.service" "${pkgdir}/usr/lib/systemd/system/setroubleshootd.service"
- install -m644 -D "../setroubleshoot-sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/setroubleshoot.conf"
- install -m644 -D "../setroubleshoot.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/setroubleshoot.conf"
- install -m755 -D "src/sedispatch" "${pkgdir}/usr/bin/sedispatch"
- install -m755 -D "src/setroubleshootd" "${pkgdir}/usr/bin/setroubleshootd"
-
- install -m644 -D "org.fedoraproject.Setroubleshootd.service" "${pkgdir}/usr/share/dbus-1/system-services/org.fedoraproject.Setroubleshootd.service"
- install -m644 -D "org.fedoraproject.SetroubleshootFixit.service" "${pkgdir}/usr/share/dbus-1/system-services/org.fedoraproject.SetroubleshootFixit.service"
- install -m644 -D "org.fedoraproject.SetroubleshootPrivileged.service" "${pkgdir}/usr/share/dbus-1/system-services/org.fedoraproject.SetroubleshootPrivileged.service"
-
- install -m644 -D "src/setroubleshoot.conf" "${pkgdir}/etc/setroubleshoot/setroubleshoot.conf"
- install -m644 -D "org.fedoraproject.Setroubleshootd.conf" "${pkgdir}/etc/dbus-1/system.d/org.fedoraproject.Setroubleshootd.conf"
- install -m644 -D "org.fedoraproject.SetroubleshootFixit.conf" "${pkgdir}/etc/dbus-1/system.d/org.fedoraproject.SetroubleshootFixit.conf"
- install -m644 -D "org.fedoraproject.SetroubleshootPrivileged.conf" "${pkgdir}/etc/dbus-1/system.d/org.fedoraproject.SetroubleshootPrivileged.conf"
-
- install -m644 -D "org.fedoraproject.setroubleshootfixit.policy" "${pkgdir}/usr/share/polkit-1/actions/org.fedoraproject.setroubleshootfixit.policy"
-
- install -m644 -D "src/SetroubleshootFixit.py" "${pkgdir}/usr/share/setroubleshoot/SetroubleshootFixit.py"
- install -m644 -D "src/SetroubleshootPrivileged.py" "${pkgdir}/usr/share/setroubleshoot/SetroubleshootPrivileged.py"
-
-for lang in "as" "bg" "bn" "bn_IN" "ca" "cs" "da" "de" "el" "en_GB" "es" "eu" "fi" "fr" "fur" "gl" "gu" "he" "hi" "hr" "hu" "it" "ja" "kn" "ko" "mai" "ml" "mr" "ms" "nb" "nds" "nl" "nn" "or" "pa" "pl" "pt" "pt_BR" "ru" "si" "sk" "sr" "sr@latin" "sv" "ta" "te" "th" "tr" "uk" "zh_CN" "zh_TW"; do
- if [ -f "${srcdir}/locale/$lang/LC_MESSAGES/setroubleshoot.pmo" ]; then
- install -Dm644 "${srcdir}/locale/$lang/LC_MESSAGES/setroubleshoot.pmo" "${pkgdir}/usr/share/locale/$lang/LC_MESSAGES/setroubleshoot.pmo"
- fi
- if [ -f "${srcdir}/locale/$lang/LC_MESSAGES/setroubleshoot.mo" ]; then
- install -Dm644 "${srcdir}/locale/$lang/LC_MESSAGES/setroubleshoot.mo" "${pkgdir}/usr/share/locale/$lang/LC_MESSAGES/setroubleshoot.mo"
- fi
-done
-
- mkdir -p "${pkgdir}/run/setroubleshoot/"
- chmod 755 "${pkgdir}/run/setroubleshoot/"
- mkdir -p "${pkgdir}/var/lib/setroubleshoot"
- touch "${pkgdir}/var/lib/setroubleshoot/setroubleshoot_database.xml"
- touch "${pkgdir}/var/lib/setroubleshoot/email_alert_recipients"
- chown -R setroubleshoot "${pkgdir}/var/lib/setroubleshoot"
- chmod 600 "${pkgdir}/var/lib/setroubleshoot/setroubleshoot_database.xml"
- chmod 600 "${pkgdir}/var/lib/setroubleshoot/email_alert_recipients"
- chmod 750 "${pkgdir}/etc/audit/plugins.d/"
-
- # SETroubleshootD requires an audit event socket to function
- sudo sed -i 's/active = no/active = yes/g' /etc/audit/plugins.d/af_unix.conf
-}