summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad0772b3b11c..576470139d78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
+# Maintainer: Joel <aullidolunar (at) gmai1 dot c0m >
# Maintainer: Oguzcan Kucukbayrak <oguz@okb1100.com>
pkgname=shadow-icon-theme
-pkgver=2.2.2
-pkgrel=1
-pkgdesc="This is a flat icon-theme Gnome 3.10+. The icons have colourful circular base with long shadow. "
+pkgver=3.0
+pkgrel=0
+pkgdesc="This is a flat icon-theme Gnome 3.10+. The icons have colourful circular base with long shadow."
arch=(any)
-url="http://gnome-look.org/content/show.php/Shadow?content=170398"
+url="https://www.gnome-look.org/content/show.php/Shadow?content=170398"
license=(GPL3)
-source=("https://dl.opendesktop.org/api/files/download/id/1473335366/shadow-${pkgver}.tar.xz")
-md5sums=('d0b4df239435ef4f5139de8165409fcc')
+makedepends=('git')
-package() {
- install -d "${pkgdir}"/usr/share/icons/
- tar -xf shadow-${pkgver}.tar.xz
- cp -r shadow/ "${pkgdir}"/usr/share/icons/
+source=(git+https://github.com/rudrab/Shadow.git)
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/Shadow"
+ mkdir -p "$pkgdir/usr/share/icons/shadow"
+ find . -type d -name ".git" -prune -o -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/icons/shadow/{}" \;
}