summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9460858dc8dc..18be5e1bcf3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer : chrisl echo archlinux@c2h0r1i2s4t5o6p7h8e9r-l3u4n1a.com|sed 's/[0-9]//g'
-# Maintainer: Dany Martineau <dany.luc.martineau gmail.com>
+# Maintainer: Francesco Minnocci <ascoli dot minnocci at gmail dot com>
+# Contributor : chrisl echo archlinux@c2h0r1i2s4t5o6p7h8e9r-l3u4n1a.com|sed 's/[0-9]//g'
+# Contributor: Dany Martineau <dany.luc.martineau gmail.com>
# Contributor: Stefan Clarke <fm0nk3y@yahoo.co.uk>
pkgname=shantz-xwinwrap-bzr
pkgver=20090421
-pkgrel=3
+pkgrel=5
pkgdesc="Utility to play Movies on your Desktop Or ElectricSheep"
[ "$CARCH" = "i686" ] && ARCH=x86
[ "$CARCH" = "x86_64" ] && ARCH=x86_64
arch=(i686 x86_64)
url="https://shantanugoel.com/2008/09/03/shantz-xwinwrap/"
-license=(Other/Open Source)
+license=(MIT)
depends=(libxext libxrender)
provides=('xwinwrap')
conflicts=('xwinwrap')
-makedepends=('bzr' 'make')
-
-source=()
-md5sums=()
+makedepends=('bzr' 'python-dulwich')
+source=('LICENSE')
+sha512sums=('SKIP')
_bzrroot="lp:xwinwrap"
_bzrmod="xwinwrap"
@@ -28,16 +28,17 @@ build() {
bzr branch $_bzrroot
cd $_bzrmod
if [ "$CARCH" == "i686" ]; then
- make all32 || return 1
+ make all32
else
- make all64 || return 1
+ make all64
fi
}
package() {
- cd $_bzrmod
+ cd ${srcdir}
if [ "$CARCH" == "i686" ]; then
- install -D -m0755 ${srcdir}/xwinwrap/i386/xwinwrap ${pkgdir}/usr/bin/xwinwrap || return 1
+ install -D -m0755 xwinwrap/i386/xwinwrap ${pkgdir}/usr/bin/xwinwrap
else
- install -D -m0755 ${srcdir}/xwinwrap/x86_64/xwinwrap ${pkgdir}/usr/bin/xwinwrap || return 1
+ install -D -m0755 xwinwrap/x86_64/xwinwrap ${pkgdir}/usr/bin/xwinwrap
fi
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}