summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c7d112476cf..30970296459f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Jonne Haß <me@jhass.eu>
pkgname=shards-git
-pkgver=v0.5.0.r0.ga501f92
+pkgver=v0.17.3.r2.geac9adf
pkgrel=1
pkgdesc="The package manager for the Crystal language (git version)"
-arch=('i686' 'x86_64')
-url="https://github.com/ysbaddaden/shards"
+arch=('x86_64' 'aarch64')
+url="https://github.com/crystal-lang/shards"
license=('Apache')
conflicts=('shards')
provides=('shards')
-depends=('libyaml' 'git' 'libpcl' 'libevent' 'gc')
+depends=('libyaml' 'git' 'libevent' 'gc')
+optdepends=('fossil')
makedepends=('crystal')
-source=("git+https://github.com/ysbaddaden/shards.git")
+checkdepends=('fossil')
+source=("git+https://github.com/crystal-lang/shards.git")
pkgver() {
cd "$srcdir/${pkgname/-git/}"
@@ -23,19 +25,19 @@ pkgver() {
build() {
cd "${pkgname/-git/}"
- crystal build --release -o bin/shards src/shards.cr
+ make CRYSTAL_OPTS="--release"
}
check() {
cd "${pkgname/-git/}"
./bin/shards install
- make -j1 test
+ make test
}
package() {
cd "${pkgname/-git/}"
-
- install -Dm755 bin/shards "$pkgdir/usr/bin/shards"
+
+ make install PREFIX="$pkgdir/usr"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
sha256sums=('SKIP')