summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f2f9d124949..fe73ec60df5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
_pkgname='shd'
pkgname="$_pkgname-git"
-pkgver='0.1.3.r2.g8c68335'
+pkgver='0.1.4.r6.g7c05853'
pkgrel='1'
pkgdesc='Console tool to display drive list with commonly checked smart info - git version'
-arch=('x86_64' 'i686' 'arm' 'aarch64')
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://github.com/alttch/$_pkgname"
license=('MIT')
-depends=('smartmontools')
+depends=('smartmontools>=7.0')
makedepends=('cargo' 'git')
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -22,11 +22,10 @@ prepare() {
# Prepare correct target for our architecture
_cargotarget="$CARCH-unknown-linux-musl"
- if [ "$CARCH" = 'arm' ]; then
- _cargotarget="${_cargotarget}eabihf"
+ if [ "$CARCH" = 'armv7h' ]; then
+ _cargotarget='armv7-unknown-linux-musleabihf'
fi
- cargo update
cargo fetch --locked --target "$_cargotarget"
}
@@ -38,12 +37,12 @@ pkgver() {
build() {
cd "$srcdir/$_sourcedirectory/"
export RUSTUP_TOOLCHAIN='stable'
- export CARGO_TARGET_DIR='build'
+ export CARGO_TARGET_DIR='target'
cargo build --frozen --release --all-features
}
package() {
cd "$srcdir/$_sourcedirectory/"
- install -Dm755 "build/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 "target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}