summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49ace4cb9eef..2af5eb3dc5e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
# Maintainer: George Rawlinson <grawlinson@archlinux.org>
pkgname=sheldon
-pkgver=0.6.4
-pkgrel=1
+pkgver=0.6.6
+pkgrel=2
pkgdesc="A fast and configurable shell plugin manager"
arch=('x86_64')
url="https://sheldon.cli.rs"
license=('Apache' 'MIT')
depends=('curl')
makedepends=('git' 'rust' 'mdbook-linkcheck')
-_commit='34a71135a1aa097da6fedde1b16a0ae222244a46'
+options=('!lto')
+_commit='31c6df8f7da1d9aed7b46d75bc6c0fd8a0616c54'
source=("git+https://github.com/rossmacarthur/sheldon.git#commit=$_commit")
b2sums=('SKIP')
pkgver() {
cd "$pkgname"
- git describe --tags | sed 's/^[vV]//;s/-/+/g'
+
+ git describe --tags | sed 's/^v//'
}
prepare() {
cd "$pkgname"
+
+ # backport fix for tests
+ git cherry-pick --no-commit 9aa06fdd5cb284daae8c48648d614e3823f3f9f3
+
+ # download dependencies
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
@@ -35,6 +42,7 @@ build() {
check() {
cd "$pkgname"
+
cargo test --frozen --all-features
}
@@ -49,4 +57,8 @@ package() {
# documentation
install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" *.md
+
+ # completions
+ install -vDm644 completions/sheldon.bash "$pkgdir/usr/share/bash-completion/completions/$pkgname"
+ install -vDm644 completions/sheldon.zsh "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
}