summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 26 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6fa38724507..994f097ab9d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Markus Hovorka <m.hovorka@live.de>
+# Contributor: Markus Hovorka <m.hovorka@live.de>
# Contributor: Florian Pritz <bluewind@xinu.at>
# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
@@ -6,18 +6,16 @@
pkgbase=shiboken2-git
pkgname=(python{2,}-shiboken2-git shiboken2-git)
-pkgver=2.0.0.r2539.8f3761d
+pkgver=2.0.0.r5325.ad14f649
_upver=2.0.0
pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL')
url="http://www.pyside.org"
-makedepends=('git' 'clang' 'llvm' 'cmake' 'python2' 'python' 'libxslt'
+makedepends=('git' 'clang' 'cmake' 'python2' 'python' 'libxslt'
'qt5-xmlpatterns')
-source=("$pkgbase::git+https://code.qt.io/pyside/shiboken.git#branch=5.9"
- "sphinx-build2.patch")
-md5sums=('SKIP'
- '915d0fc351ff2e7c5deaa1066aeeae67')
+source=("$pkgbase::git+https://code.qt.io/pyside/pyside-setup.git#branch=5.9")
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgbase"
@@ -26,27 +24,33 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgbase"
- patch -Np1 -i "$srcdir/sphinx-build2.patch"
}
build(){
# Build for python2.
- cd "$srcdir/$pkgbase"
+ cd "$srcdir"/$pkgbase/sources/shiboken2
mkdir -p build-py2 && cd build-py2
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DPYTHON_EXTENSION_SUFFIX=-python2.7 \
- -DUSE_PYTHON_VERSION=2 \
- -DBUILD_TESTS=OFF
+ cmake \
+ -DCMAKE_C_COMPILER=/usr/bin/clang \
+ -DCMAKE_CXX_COMPILER=/usr/bin/clang++ \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTS=OFF \
+ -DUSE_PYTHON_VERSION=2 \
+ -DBUILD_TESTS=OFF ..
make
# Build for python3.
- cd "$srcdir/$pkgbase"
+ cd "$srcdir"/$pkgbase/sources/shiboken2
mkdir -p build-py3 && cd build-py3
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DUSE_PYTHON_VERSION=3 \
- -DBUILD_TESTS=OFF
+ cmake \
+ -DCMAKE_C_COMPILER=/usr/bin/clang \
+ -DCMAKE_CXX_COMPILER=/usr/bin/clang++ \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTS=OFF \
+ -DUSE_PYTHON_VERSION=3 \
+ -DBUILD_TESTS=OFF ..
make
}
@@ -56,7 +60,7 @@ package_shiboken2-git() {
optdepends=("python2-shiboken2-git: for compilation against python2"
"python-shiboken2-git: for compilation against python")
- cd "$srcdir/$pkgbase/build-py3"
+ cd "$srcdir"/$pkgbase/sources/shiboken2/build-py3
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir/usr/lib/python"*
@@ -69,7 +73,7 @@ package_python2-shiboken2-git() {
pkgdesc="Support library for Python2 bindings"
depends=("python2" "shiboken2-git")
- cd "$srcdir/$pkgbase/build-py2"
+ cd "$srcdir"/$pkgbase/sources/shiboken2/build-py2
make DESTDIR="$pkgdir" install
mv "$pkgdir"/usr/lib/pkgconfig/shiboken2{,-py2}.pc
@@ -83,7 +87,7 @@ package_python-shiboken2-git() {
pkgdesc="Support library for Python bindings"
depends=("python" "shiboken2-git")
- cd "$srcdir/$pkgbase/build-py3"
+ cd "$srcdir"/$pkgbase/sources/shiboken2/build-py3
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/usr/{include,bin,share}