summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8430a3989ab5..fbb6699bfbb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=shinden-client-bin
-pkgver=3.1.1
+pkgver=3.1.2
_electronversion=29
-pkgrel=2
-pkgdesc="Unofficial client for the polish anime websites. It allows you to watch anime without being exposed to ads and pop-ups."
+pkgrel=1
+pkgdesc="Unofficial client for the polish anime websites. It allows you to watch anime without being exposed to ads and pop-ups.(Prebuilt version.Use system-wide electron)"
arch=("x86_64")
url="https://github.com/KlapChat-Entertainment/shinden-client"
license=('MIT')
@@ -13,21 +13,23 @@ depends=(
"electron${_electronversion}"
)
source=(
- "${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}-electron_${pkgver}_amd64.deb"
+ "${pkgname%-bin}-${pkgver}.rpm::${url}/releases/download/v${pkgver}/${pkgname%-bin}-electron-${pkgver}-1.${CARCH}.rpm"
"${pkgname%-bin}.sh"
)
-sha256sums=('cd2f91eb2fcb5c8a65b24311395eada8efcfb8c59ea07a5af2c944de38cdeeb2'
- '2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051')
+sha256sums=('b8daf5f4efa78ad17223fae44eea82b2502a09b2bd483ec390fff09e0a56fe68'
+ '291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980')
build() {
- sed -e "s|@electronversion@|${_electronversion}|g" \
- -e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@runname@|app.asar|g" \
- -e "s|@cfgdirname@|${pkgname%-bin}-electron|g" \
- -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
- -i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data."*
- sed "s|${pkgname%-bin}-electron|${pkgname%-bin}|g;s|${pkgname%-bin}-electron|${pkgname%-bin}|g" \
- -i "${srcdir}/usr/share/applications/${pkgname%-bin}-electron.desktop"
+ sed -e "
+ s/@electronversion@/${_electronversion}/g
+ s/@appname@/${pkgname%-bin}/g
+ s/@runname@/app.asar/g
+ s/@cfgdirname@/${pkgname%-bin}-electron/g
+ s/@options@/env ELECTRON_OZONE_PLATFORM_HINT=auto/g
+ " -i "${srcdir}/${pkgname%-bin}.sh"
+ sed -e "
+ s/${pkgname%-bin}-electron %U/${pkgname%-bin} %U/g
+ s/Icon=${pkgname%-bin}-electron/Icon=${pkgname%-bin}/g
+ " -i "${srcdir}/usr/share/applications/${pkgname%-bin}-electron.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
@@ -35,4 +37,4 @@ package() {
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}-electron.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/usr/share/pixmaps/${pkgname%-bin}-electron.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
install -Dm644 "${srcdir}/usr/share/doc/${pkgname%-bin}-electron/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-} \ No newline at end of file
+}