summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e25bd233200d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Author: rr- <rr-@sakuya.pl>
+# Maintainer: rr- <rr-@sakuya.pl>
+pkgname=shot-git
+pkgver=2.1
+pkgrel=1
+pkgdesc='A minimal screenshot tool aiming to provide good control over screenshot region.'
+arch=('any')
+url='https://github.com/rr-/shot'
+license=('GPL')
+depends=('git' 'gcc' 'xorg-xrandr' 'python' 'wget')
+source=("$pkgname::git://github.com/rr-/shot.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --tags --abbrev=0
+}
+
+build() {
+ cd "$pkgname"
+ ./bootstrap
+ ./waf configure
+ ./waf
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 build/shot "$pkgdir/usr/bin/shot"
+ install -Dm644 docs/shot.1 "$pkgdir/usr/share/man/man1/shot.1p"
+}