summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 12 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd60bafcc545..2fca2fc84f9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,20 @@
pkgname=shrew-vpn-client
pkgver=2.2.1
-pkgrel=4
-pkgdesc="A portable VPN client for Linux with Qt GUI"
+pkgrel=5
+pkgdesc="A portable VPN client for Linux - Qt GUI only"
arch=('i686' 'x86_64')
url="http://www.shrew.net/"
license=('osi')
-depends=('qt4' 'openssl-1.0')
+depends=('qt4' 'ike')
makedepends=('gcc' 'flex' 'libedit' 'bison' 'cmake')
-optdepends=('openldap' 'logrotate')
conflicts=('shrew-vpn-client-alpha')
-backup=('etc/iked.conf')
source=("http://www.shrew.net/download/ike/ike-$pkgver-release.tbz2"
'ikea.desktop'
- 'iked.conf'
- 'iked.service'
- fix-openssl.patch
- fix_dirent_access_after_closedir.patch)
+ gui_only.patch)
md5sums=('8fc14ac86771ee693d3950757c84f335'
'5b35a4246eb1b7bd4bfb6780c23d39f2'
- '3cfe649578267235d60ab7cfb6fb4c57'
- 'e90d5922d37f9e45515c5754a3a29c73'
- 'c1f793c174db5d7f5c11c8009a967a4d'
- 'cb4720dab4f9cae5aeac1e62abc6348b')
-
-prepare() {
-
- cd $srcdir/ike
- patch -Np1 -i ../fix-openssl.patch
- # https://build.opensuse.org/package/view_file/security/ike/fix_dirent_access_after_closedir.patch
- patch -Np1 -i ../fix_dirent_access_after_closedir.patch
-
-}
+ 'eed8f22eedb29cad06abcfe8e513b028')
build() {
cd $srcdir/ike
@@ -41,6 +24,13 @@ build() {
# Build the whole package
cmake -DQTGUI=YES -DNATT=YES -DLDAP=YES -DSBINDIR=/usr/bin \
-DCMAKE_INSTALL_PREFIX=/usr -DMANDIR=/usr/share/man -DETCDIR=/etc
+
+ # Remove binary and library from make
+ patch -Np1 -i ../gui_only.patch
+# for Component in iked ikec libike libip libidb libith liblog libpfk ; do
+# sed -e "/\/$Component\//d" -i cmake_install.cmake
+# done
+
make
}
@@ -48,15 +38,6 @@ package() {
cd "$srcdir/ike"
make DESTDIR="$pkgdir/" install
- # Install the daemon script
- install -D -m644 $startdir/iked.service $pkgdir/usr/lib/systemd/system/iked.service
-
- # The configuration file is already ready for use; just rename it
- mv $pkgdir/etc/iked.conf.sample $pkgdir/etc/iked.conf
-
- # Prevent logs from growing if logrotate is installed
- install -D -m644 $startdir/iked.conf $pkgdir/etc/logrotate.d/iked.conf
-
# Copy our desktop files
install -D -m644 $srcdir/ike/source/qikea/png/ikea.png $pkgdir/usr/share/icons/ikea.png
install -D -m755 $startdir/ikea.desktop $pkgdir/usr/share/applications/ikea.desktop