summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2679f8618981..3e726725a875 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,25 @@
pkgname=shrinky-intro
pkgver=0.1
-pkgrel=1
-pkgdesc='Linux 4k intro skeleton'
+pkgrel=2
+pkgdesc='Linux 4k intro skeleton (from dnload)'
arch=('x86_64')
-url="http://github.org/xyproto/shrinky-intro/"
+url='https://github.org/xyproto/shrinky-intro/'
license=('BSD')
-makedepends=('shrinky')
+makedepends=('git' 'shrinky')
depends=('libgl' 'sdl2')
-optdepends=('elfkickers: For stripping with sstrip'
- 'vulkan-devel: For Vulkan development')
-source=("git+https://github.com/xyproto/shrinky-intro#commit=438ad8b197ff15fb561fe3a0b15d602486e90244")
+#optdepends=('elfkickers: For stripping with sstrip'
+# 'vulkan-devel: For Vulkan development')
+source=('git+https://github.com/xyproto/shrinky-intro#commit=438ad8b197ff15fb561fe3a0b15d602486e90244')
md5sums=("SKIP")
build() {
- shrinky "$pkgname/main.cpp"
+ shrinky $pkgname/main.cpp
}
package() {
- cd "$pkgname"
- install -Dm755 main "$pkgdir/usr/bin/$pkgname"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 $pkgname/main "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim: ts=2 sw=2 et: