summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 25 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d68a267a85b9..725484a165a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,60 @@
# Maintainer: willemw <willemw12@gmail.com>
+# NOTE This PIP package behaves like a VCS package: to update, reinstall the package.
+# That is the only reason why this package ends on -git.
+
pkgname=sickchill-git
-pkgver=2020.07.09.1.r266.g319d20e55
+pkgver=0.0.55.r0
pkgrel=1
pkgdesc="Automatic video library manager for TV shows"
arch=('any')
-url="https://github.com/SickChill/SickChill"
+url="https://sickchill.github.io"
license=('GPL3')
-depends=('nodejs' 'python')
-makedepends=('git' 'python-pygithub')
+depends=('nodejs' 'python-pip' 'python-pyopenssl' 'python-virtualenv')
+makedepends=('python-virtualenv')
# 'deluge: supported torrent client'
# 'qbittorrent: supported torrent client'
# 'rtorrent: supported torrent client'
# 'sabnzbd: supported NZB downloader'
# 'transmission-cli: supported torrent client'
+#mediainfo
optdepends=('unrar: for RAR archives')
provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
options=('!strip')
install=$pkgname.install
-#source=("$pkgname::git+$url.git"
-source=("$pkgname::git+$url.git#branch=develop"
- 'sickchill.service'
+source=('sickchill.service'
'sickchill.sysusers'
'sickchill.tmpfile')
-md5sums=('SKIP'
- 'fe1030d29e883682a9c3117867edd9d8'
+md5sums=('309b8555af7b355f16a3ec784771f426'
'97fb191af2e326d5aba2cf58270b4feb'
'515f13e391105a716ef6763ba8533fc7')
pkgver() {
- cd $pkgname
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ pip search "${pkgname%-git}" | awk '$1 == "'${pkgname%-git}'" { gsub("[()]", ""); print $2 ".r0" }'
+}
+
+prepare() {
+ rm -rf build
}
-#build() {
-# cd $pkgname
-# python setup.py --quiet build
-#}
+build() {
+ mkdir -p build
+ cd build
-#check() {
-# cd $pkgname
-# python setup.py test
-#}
+ virtualenv .
+ ./bin/pip install --isolated --no-warn-script-location --root=. --prefix=. sickchill
+
+ sed -i '1s|.*|#!/opt/sickchill/app/bin/python|' bin/SickChill.py
+}
package() {
install -Dm644 sickchill.service "$pkgdir/usr/lib/systemd/system/sickchill.service"
install -Dm644 sickchill.sysusers "$pkgdir/usr/lib/sysusers.d/sickchill.conf"
install -Dm644 sickchill.tmpfile "$pkgdir/usr/lib/tmpfiles.d/sickchill.conf"
- install -dm755 "$pkgdir"/opt/sickchill/{app,data}
-
- # The install type is "source": .git folder is not included
- #cd $pkgname
- #python setup.py install --prefix=/opt/sickchill/app --install-lib=/opt/sickchill/app --root="$pkgdir" --optimize=1
- cp -a $pkgname/* "$pkgdir/opt/sickchill/app/"
+ install -dm755 "$pkgdir"/opt/sickchill/data
+ cp -a build "$pkgdir/opt/sickchill/app"
warning "If the upgrade fails with \"error: failed to commit transaction (conflicting files)\", then uninstall first"
}