summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 7 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c35a26ee4bb1..4d3395738063 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,13 @@
# Maintainer: willemw <willemw12@gmail.com>
-_pkgname=sickchill
-pkgname=$_pkgname-git
-pkgver=2018.10.27.2.r1.g4f7a2a56d
+pkgname=sickchill-git
+pkgver=2020.01.14.2.r0.g4dedd01fc
pkgrel=1
pkgdesc="Automatic video library manager for TV shows"
arch=('any')
url="https://github.com/SickChill/SickChill"
license=('GPL3')
-#'python2-vcr' 'unrar'
makedepends=('git')
-depends=('nodejs' 'python2-babel' 'python2-cheetah' 'python2-mako')
# 'deluge: supported torrent client'
# 'qbittorrent: supported torrent client'
# 'rtorrent: supported torrent client'
@@ -18,16 +15,16 @@ depends=('nodejs' 'python2-babel' 'python2-cheetah' 'python2-mako')
# 'transmission-cli: supported torrent client'
optdepends=('python2-notify: desktop notifications'
'unrar: RAR archives')
-provides=($_pkgname 'sickrage')
-conflicts=($_pkgname 'sickrage')
+provides=(${pkgname%-git})
+conflicts=(${pkgname%-git})
options=('!strip')
install=$pkgname.install
-source=("$pkgname::git+https://github.com/SickChill/SickChill.git"
+source=("$pkgname::git+$url.git"
'sickchill.service'
'sickchill.sysusers'
'sickchill.tmpfile')
md5sums=('SKIP'
- 'fd497f3e93f4920f39714be53b0f8809'
+ '5f5c96bdeb4eb5665af2bcebf0ceca53'
'97fb191af2e326d5aba2cf58270b4feb'
'515f13e391105a716ef6763ba8533fc7')
@@ -36,11 +33,6 @@ pkgver() {
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-#prepare() {
-# cd $pkgname
-# sed -i 's/UnRAR2/unrar2/g' lib/unrar2/test_UnRAR2.py
-#}
-
#build() {
# cd $pkgname
# python2 setup.py --quiet build
@@ -49,9 +41,6 @@ pkgver() {
#check() {
# cd $pkgname
# python2 setup.py test
-#
-# cd lib/unrar2
-# PYTHONPATH="$(pwd)/..:$PYTHONPATH" python2 test_UnRAR2.py
#}
package() {
@@ -64,7 +53,7 @@ package() {
# The install type is "source": .git folder is not included
#cd $pkgname
#python2 setup.py install --prefix=/opt/sickchill/app --install-lib=/opt/sickchill/app --root="$pkgdir" --optimize=1
- cp -rp $pkgname/* "$pkgdir/opt/sickchill/app/"
+ cp -a $pkgname/* "$pkgdir/opt/sickchill/app/"
warning "If the upgrade fails with \"error: failed to commit transaction (conflicting files)\", then uninstall first"
}