summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e488fa12f84d..e05c536e4684 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=sickgear
pkgname=${_pkgname}-git
pkgver=0.11.12.r0.g9198eb6
-pkgrel=2
+pkgrel=3
pkgdesc="Provides management of TV shows and/or Anime, detects new episodes, links to downloader apps, and more."
arch=('any')
url="https://github.com/SickGear/SickGear"
@@ -28,16 +28,18 @@ conflicts=(${_pkgname}
options=('!strip')
install=${_pkgname}.install
+_source="https://github.com/SickGear/SickGear.git"
+
source=('sickgear.service'
'sickgear.tmpfiles'
'sickgear.sysusers'
'fix-signal-handling.patch'
- "${_pkgname}::git+https://github.com/SickGear/SickGear.git")
+ "${_pkgname}::git+${_source}")
sha256sums=('76108d56417bc6e5352db779c7e74812eda07b440cc293547809aa9504e10209'
'5c7a327168f2b2d361eeaa9e9f82e79a87381908d8ba6b1d1eb90ac64ad38ac2'
'54873ee12aa334a0c0830dbe48251f994d8ae851ae0b55250c098ff9f7f9ea60'
- 'fae4616bf9dbf19d5bb2fcc89abd49b27db9f1f0181589a60bbcde07b840ae99'
+ '8da4938dbba87fbb7c88715d03ceff51544ed79cff3c8ea0ed31866a7d345083'
'SKIP')
pkgver() {
@@ -46,7 +48,10 @@ pkgver() {
}
prepare() {
- cd "${_pkname}"
+ cd "${_pkgname}"
+
+ # Change origin back to upstream to allow updates
+ git remote set-url origin "${_source}"
# Patch to fix SIGINT and SIGTERM signal handling
patch -Np1 -i "${srcdir}/fix-signal-handling.patch"