summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa092cdf02e8..036fcba082c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
pkgname=siesta
-pkgver=4.1
+pkgver=4.1.5
pkgrel=1
pkgdesc="A first-principles materials simulation code using DFT"
arch=("x86_64")
-url="www.uam.es/siesta"
+url="https://departments.icmab.es/leem/siesta"
license=('GPL')
depends=('elpa' 'metis' 'fftw' 'python')
makedepends=('gcc-fortran')
-source=("https://gitlab.com/siesta-project/siesta/-/archive/rel-$pkgver/$pkgname-rel-$pkgver.tar.bz2")
-sha256sums=('07d724a143b245e7c79dc996b5bf13936497444827a91653249b4775fc1fdcf0')
+source=("https://gitlab.com/siesta-project/siesta/-/archive/v$pkgver/$pkgname-v$pkgver.tar.bz2")
+sha256sums=('0beffa6b8c3f705348acba2ac619e8ad749f54bcaa1c7bb560e994a9f7f502d8')
prepare() {
# Whereas the configure script was removed from the distribution,
- # one is required to adjust arch.make to set up building environment.
- cd $pkgname-rel-$pkgver/Obj
+ # we have to adjust arch.make to set up building environment.
+ cd "$pkgname-v$pkgver/Obj"
cp DOCUMENTED-TEMPLATE.make arch.make
sed -i '/CC =/c CC = mpicc' arch.make
sed -i '/FC =/c FC = mpifort' arch.make
- sed -i '/FFLAGS =/c FFLAGS = -O3 -fPIC -ftree-vectorize -march=native -fopenmp' arch.make
+ sed -i '/FFLAGS =/c FFLAGS = -O3 -fPIC -march=native -fopenmp -fallow-argument-mismatch' arch.make
sed -i 's/unknown/archlinux/g' arch.make
sed -i 's/COMP_LIBS =/#COMP_LIBS =/' arch.make
sed -i 's/$(COMP_LIBS)/$(COMP_LIBS) -lgomp/g' arch.make
@@ -39,7 +39,7 @@ prepare() {
}
build() {
- cd $pkgname-rel-$pkgver/Obj
+ cd "$pkgname-v$pkgver/Obj"
../Src/obj_setup.sh
make FPPFLAGS="-DMPI -DSIESTA__METIS -DSIESTA__ELPA -I/usr/include/elpa_openmp-$_elpaver/modules"
cp siestaxc.mod ../Src
@@ -49,10 +49,11 @@ build() {
}
package() {
- cd $pkgname-rel-$pkgver
- install -dm755 $pkgdir/opt/siesta
- install -dm755 $pkgdir/usr/bin
- find ./Util -type f ! -name "*.sh" -executable -exec install -m755 {} "$pkgdir/opt/siesta" ";"
- install -m755 ./Obj/siesta $pkgdir/opt/siesta
- ln -sf $pkgdir/opt/siesta/siesta $pkgdir/usr/bin
+ cd "$pkgname-v$pkgver"
+ install -dm755 "$pkgdir/opt/siesta"
+ install -dm755 "$pkgdir/usr/bin"
+ find ./Util -type f ! -name "*.sh" -executable \
+ -exec install -m755 {} "$pkgdir/opt/siesta" ";"
+ install -m755 ./Obj/siesta "$pkgdir/opt/siesta"
+ ln -sf "$pkgdir/opt/siesta/siesta" "$pkgdir/usr/bin"
}