summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 612723e20592..2d868389cb63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Mantas Mikulėnas <grawity@gmail.com>
# Developer: MitSoft <signa-support@mitsoft.lt>
pkgname=signa-browser-ext
-r=8899
-d=2019-07-03
+r=9480
+d=2020-01-13
pkgver=1.0.r${r}.${d//-}
pkgrel=1
pkgdesc="Native helper for web login using Lithuanian identity cards (for SoDra, VMI, &c)"
url="https://www.mitsoft.lt/kontaktai/"
arch=(any)
license=('custom')
-depends=('pcsclite>=1.5' 'jre8-openjdk')
+depends=('pcsclite>=1.5' 'jre11-openjdk')
source=("https://www.mitsoft.lt/sites/mitsoft/files/SignaBrowserExt_r${r}_${d}_Linux.zip")
-sha256sums=('33da52fa41df44c1e91a6874335a232bc96784ebf2416711e5e27e355bf31c7e')
+sha256sums=('7404b08bbefb47520b594546081ef6b7dcec4d1f1aa9b632fa8b2a740a04fe54')
# Update check:
# curl -I https://www.mitsoft.lt/sites/mitsoft/files/SignaBrowserExt_Linux.zip
@@ -24,17 +24,10 @@ prepare() {
rm -rf */
#bsdtar xf "signa-browser-ext-1.0-r${r}-${d//-}-noarch.rpm"
bsdtar xf "signa-browser-ext-1.0.r${r}.${d//-}-1-any.pkg.tar.xz"
-
- # Apparently they now provide an Arch package as of r7771, which is cool.
- # However, (as far as my inbox knows), they haven't expressed interest in
- # maintaining this package in AUR.
-
- # Also I think I'm technically violating the license by having this on AUR,
- # but oh well
}
build() {
- jre_dir="/usr/lib/jvm/java-8-openjdk/jre"
+ jre_dir="/usr/lib/jvm/java-11-openjdk"
sed -i "s|^java=.*|java='$jre_dir/bin/java'|" opt/signa-browser-ext/java
}