summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 22 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d02f58ed8fc..aa792c57c4e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,29 +5,30 @@ _pkgname=sile
pkgname=$_pkgname-luajit
pkgdesc='Modern typesetting system inspired by TeX'
pkgver=0.11.1
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url=https://www.sile-typesetter.org
license=(MIT)
-_lua_deps=(bit32 # Upstream Issue: https://github.com/sile-typesetter/sile/issues/1189
- cassowary
- compat53 # Not needed for Lua 5.3+, LuaJIT is 5.1(ish)
- cosmo
- cliargs
- expat
- filesystem
- linenoise
- lpeg
- luaepnf
- penlight
- repl
- sec
- socket
- stdlib
- utf8
- vstruct
- zlib)
-depends=(fontconfig
+_luadeps=(bit32
+ cassowary
+ cliargs
+ compat53 # Not needed for Lua 5.3+, LuaJIT is 5.1(ish)
+ cosmo
+ expat
+ filesystem
+ linenoise
+ lpeg
+ luaepnf
+ luarepl
+ luautf8
+ penlight
+ sec
+ socket
+ stdlib
+ vstruct
+ zlib)
+depends=(glibc
+ fontconfig
freetype2
harfbuzz
gentium-plus-font
@@ -35,10 +36,8 @@ depends=(fontconfig
icu
libpng # this goes with libtexpdf if ever split out to a library package
luajit
- "${_lua_deps[@]/#/lua51-}"
+ "${_luadeps[@]/#/lua51-}"
zlib)
-# Note: find via find-deps; needs rebuilding any time versions of these change;
-# currently missing several because parent packages are missing the provides=()
depends+=(libfreetype.so
libharfbuzz.so
libicudata.so