summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD67
1 files changed, 67 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23f4c21bb6bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_pkgname=sile
+pkgname=$_pkgname-luajit
+pkgdesc='Modern typesetting system inspired by TeX'
+pkgver=0.10.10
+pkgrel=1
+arch=('x86_64')
+url='https://www.sile-typesetter.org'
+license=('MIT')
+_lua_deps=('cassowary'
+ 'cosmo'
+ 'cliargs'
+ 'expat'
+ 'filesystem'
+ 'linenoise'
+ 'lpeg'
+ 'luaepnf'
+ 'penlight'
+ 'repl'
+ 'sec'
+ 'socket'
+ 'stdlib'
+ 'vstruct'
+ 'zlib')
+depends=('fontconfig'
+ 'freetype2'
+ 'harfbuzz'
+ 'gentium-plus-font'
+ 'icu'
+ 'libpng' # this goes with libtexpdf if ever split out to a library package
+ 'luajit'
+ "${_lua_deps[@]/#/lua51-}"
+ 'zlib')
+# Note find via find-deps; needs rebuilding any time versions of these change;
+# currently missing several because parent packages are missing the provides=()
+depends+=('libfreetype.so'
+ 'libharfbuzz.so'
+ 'libicudata.so'
+ 'libicui18n.so'
+ 'libicuio.so'
+ 'libicuuc.so')
+checkdepends=('poppler')
+provides=('libtexpdf.so'
+ "$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("https://github.com/sile-typesetter/sile/releases/download/v$pkgver/$_pkgname-$pkgver.tar.xz")
+sha256sums=('efc0be18118e20fa5cbde330850b3f65d0835c05a75ad45d4ee85f8ff8f6fe54')
+
+build () {
+ cd "$_pkgname-$pkgver"
+ ./configure \
+ --prefix /usr \
+ --with-luajit \
+ --with-system-luarocks
+ make all
+}
+
+check () {
+ cd "$_pkgname-$pkgver"
+ make check
+}
+
+package () {
+ cd "$_pkgname-$pkgver"
+ make install DESTDIR="$pkgdir"
+}