summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4b72a0c1fd3..7a34232408bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=silkaj
-pkgver=0.7.6
+pkgver=0.8.0
pkgrel=1
pkgdesc="Powerfull, lightweight, and multi-platform command line client written with Python for Duniter’s currencies"
@@ -14,7 +14,12 @@ depends=('python' 'python-setuptools' 'python-dephell' 'python-click' 'python-ip
'python-duniterpy' 'python-pypeg2' 'python-pylibscrypt')
source=("https://git.duniter.org/clients/python/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha512sums=('69074ddf804d79a2780bb757d0fcab8c08ec63478b215b842e536327348e4a02369b69e5c07b61dbf6245b4cf99847b583b4be853b469503ad1688aaf4732656')
+sha512sums=('68a30f03aa8420dbec89fee3aa52bb8d061ef05291516f5873a8d50f5dd7c78dbe5827e41ee710854ebd08a7ddaea572adceaff0a3040134295cb24f6c545b99')
+
+prepare() {
+ cd "$pkgname-v$pkgver"
+ dephell deps convert --from pyproject.toml --to setup.py
+}
package() {
cd "$pkgname-v$pkgver"