summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c0a4fbfc001..8998a1cb9cd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,21 @@
pkgname=sim65
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="65c02 simulation system"
arch=('i686' 'x86_64')
url="http://www.wsxyz.net/sim65/"
license=('GPL')
depends=('wxgtk')
-source=(http://www.wsxyz.net/${pkgname}/${pkgname}.tar.gz)
-md5sums=('b83a86302e55763e280638676715c391')
+source=(http://www.wsxyz.net/${pkgname}/${pkgname}.tar.gz
+ wx3.patch)
+md5sums=('b83a86302e55763e280638676715c391'
+ 'ba0b33c3e37c1c8a7d80ab135b7bdeb8')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch -p1 < "${srcdir}/wx3.patch"
+}
build() {
cd "${srcdir}/${pkgname}"
@@ -17,7 +24,7 @@ build() {
}
package() {
- install -D -m755 "${srcdir}/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m755 "${srcdir}/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}-system"
}
# vim:set ts=2 sw=2 et: