summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca27a7d7e43e..57add8209729 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
-# Maintainer: jmf <jmf at mesecons dot net>
-# Contributor: Pascal Groschwitz <p.groschwitz@googlemail.com>
+# Maintainer: Glen Dsouza <glen@teameos.org>
# Contributor: jmf <jmf at mesecons dot net>
+# Contributor: Pascal Groschwitz <p.groschwitz@googlemail.com>
pkgname=simgear-git
-pkgver=20150829
+pkgver=20151212
pkgrel=1
_gitname=simgear
pkgdesc="A set of open-source libraries designed to be used as building blocks for quickly assembling 3d simulations, games, and visualization applications."
arch=('i686' 'x86_64')
url="http://simgear.sourceforge.net/"
license=('GPL')
-depends=('glut' 'freealut' 'plib' 'openscenegraph' 'boost>=1.49')
+depends=('glu' 'glut' 'freealut' 'plib' 'openscenegraph')
optdepends=()
-makedepends=('git')
+makedepends=('boost' 'cmake' 'mesa')
provides=('simgear-git')
conflicts=('simgear')
source=(git://git.code.sf.net/p/flightgear/simgear)
md5sums=('SKIP')
+pkgver() {
+ echo "$(date +"%Y%m%d")"
+}
+
build() {
cd ${srcdir}/${_gitname}
git checkout next