summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c61678909fb7..959ebbd9b8dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
# Maintainer: Millian Poquet <millian.poquet@gmail.com>
pkgname=simgrid
-pkgver=3.32
+pkgver=3.34
pkgrel=1
pkgdesc='A scientific instrument to study the behavior of large-scale distributed systems such as Grids, Clouds, HPC or P2P systems.'
arch=('i686' 'x86_64')
url='https://simgrid.org/'
license=('LGPL')
-source=('https://framagit.org/simgrid/simgrid/-/archive/v3.32/simgrid-v3.32.tar.gz')
-depends=('boost' 'python')
+source=('https://framagit.org/simgrid/simgrid/-/archive/v3.34/simgrid-v3.34.tar.gz')
+depends=('boost' 'python' 'eigen')
makedepends=('cmake')
-md5sums=('0fcb36342dd5bc2ebeea46124ba18cb8')
+md5sums=('7dee08f0d959ea64fd6597aff64721e9')
package() {
cd "${srcdir}/${pkgname}-v${pkgver}"
cmake . \
-DCMAKE_INSTALL_PREFIX=/usr \
-Denable_compile_optimizations=ON \
- -Denable_documentation=OFF \
-Denable_lto=ON \
- -Denable_smpi=ON
+ -Denable_smpi=ON \
+ -Denable_documentation=OFF \
+ -Denable_python=OFF
make -j $(nproc)
make DESTDIR="${pkgdir}" install
}