summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 11 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac8af6d1745f..39321b736975 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,24 @@
-#
-# SimGrid: Framework for the simulation of distributed applications
-#
-
# Maintainer: Millian Poquet <millian.poquet@gmail.com>
pkgname=simgrid
pkgver=3.25
-pkgrel=1
+pkgrel=2
pkgdesc='A scientific instrument to study the behavior of large-scale distributed systems such as Grids, Clouds, HPC or P2P systems.'
arch=('i686' 'x86_64')
url='https://simgrid.org/'
license=('LGPL')
source=('https://framagit.org/simgrid/simgrid/-/archive/v3.25/simgrid-v3.25.tar.gz')
depends=('boost')
-makedepends=('cmake')
+makedepends=('cmake' 'make')
md5sums=('b1e32d5511604fb17cc919fd1de379ea')
-pkgver() {
- echo 3.25
-}
-
package() {
- mkdir -p $pkgdir/opt/simgrid
- cd $srcdir/simgrid-v3.25/
- cmake -DCMAKE_INSTALL_PREFIX=$pkgdir/opt/simgrid .
- make
- make install
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Denable_compile_optimizations=OFF \
+ -Denable_documentation=OFF \
+ -Denable_lto=OFF \
+ -Denable_smpi=ON
+ make -j $(nproc)
+ make DESTDIR="${pkgdir}" install
}