summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c670d084ca0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: R. van Elst <https://raymii.org>
+
+pkgname="simh-git"
+pkgver=4.0.Beta.1.757.gff95fb8
+pkgrel=1
+pkgdesc="The Computer History Simulation Project"
+arch=('i686' 'x86_64')
+url="http://simh.trailing-edge.com/"
+license=('MIT')
+depends=('libpcap' 'unzip')
+makedepends=()
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=('git+https://github.com/simh/simh.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ printf "%s" "$(git describe --long --tags | sed 's/v//; s/-/./g')"
+}
+
+build() {
+ cd "${pkgname%-*}"
+ make
+}
+
+package() {
+ cd "$srcdir/simh/BIN"
+ for i in *; do
+ install -D $i "$pkgdir/usr/bin/simh-$i"
+ done
+
+ cd "$srcdir/simh/VAX"
+ mkdir -p "$pkgdir/usr/lib/simh"
+ cp *.bin "$pkgdir/usr/lib/simh"
+}
+
+