summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD71
1 files changed, 71 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..3ebbe43c9af0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Simona <simona.pisano[at]gmail[dot]com>
+pkgname=simonas-scripts
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Bash unique command for mount image files (iso, vms, crypto, squashfs), detect pendrive device name, list all kernels, list all i/o schedulers, copy install files."
+
+#t does not need to be included in the source array
+changelog=$pkgname.changelog
+
+arch=('any')
+license=('GPL3')
+
+#util-linux -> lsblk
+depends=('bash' 'awk' 'util-linux' 'sed' 'sudo' )
+optdepends=('qemu: {image-mount} for mount qemu image files'
+ 'fuseiso: {image-mount} another way to mount iso image files'
+ 'cryptsetup: {image-mount} for mount crypto image files'
+ 'squashfs-tools: {image-mount} for squashfs image files'
+ 'e2fsprogs: {uuid-change} to change uuid to ext4 volumes with command tune2fs'
+ 'ntfs-3g: {uuid-change} to change uuid to ntfs volumes with command ntfslabel'
+ 'dosfstools: {uuid-change} to change uuid to fat32 volumes with command mkdosfs'
+ 'btrfs-progs: {uuid-change} to change uuid to btrfs volumes with command btrfstune' )
+
+
+source=( "boot-kernel-list"
+ "image-mount"
+ "image-umount"
+ "ioscheduler-list"
+ "pendrive-detect"
+ "simonas-scripts"
+ "uuid-change"
+ "macinstall"
+ "macinstall.conf"
+ "image-mount.1"
+ "macinstall.1"
+ "exchange-info" )
+
+backup=('etc/macinstall.d/macinstall.conf')
+
+md5sums=('3f5599c3588f01b625aa9feb0a0e8b99'
+ 'a66639338ea804997cc38af80d9249ea'
+ '861389b38ba1cd9e6bcc47b6c469e383'
+ 'c58f5737bb41c8af2bff7dd24a3d2723'
+ '40ef9e0d1831cc1865208bf52eaa2cef'
+ 'f5466c638c1692bd3b244d0fbb461914'
+ '3189eb5ae50a9ddce43c8820c35ba2b0'
+ '962dd112eb6d348f8a2efdd69b982359'
+ '6bdfded6596cd064703e37e5657a351a'
+ '261d420ae53438b3fadda33059686a33'
+ 'f3197a3b2aad5cb79b5dbab0d35fd0f9'
+ 'ad9c80d0c54c4a91f6f467ffd567b0db')
+
+package() {
+ cd "$srcdir"
+ install -Dm 755 "$srcdir/simonas-scripts" "$pkgdir/usr/bin/simonas-scripts"
+ install -Dm 755 "$srcdir/pendrive-detect" "$pkgdir/usr/bin/pendrive-detect"
+ install -Dm 755 "$srcdir/image-mount" "$pkgdir/usr/bin/image-mount"
+ install -Dm 755 "$srcdir/image-umount" "$pkgdir/usr/bin/image-umount"
+ install -Dm 755 "$srcdir/boot-kernel-list" "$pkgdir/usr/bin/boot-kernel-list"
+ install -Dm 755 "$srcdir/ioscheduler-list" "$pkgdir/usr/bin/ioscheduler-list"
+ install -Dm 755 "$srcdir/uuid-change" "$pkgdir/usr/bin/uuid-change"
+ install -Dm 755 "$srcdir/macinstall" "$pkgdir/usr/bin/macinstall"
+ install -Dm 755 "$srcdir/exchange-info" "$pkgdir/usr/bin/exchange-info"
+ install -Dm 755 "$srcdir/macinstall.conf" "$pkgdir/etc/macinstall.d/macinstall.conf"
+ install -Dm 644 "$srcdir/image-mount.1" "$pkgdir/usr/share/man/man1/image-mount.1"
+ install -Dm 644 "$srcdir/macinstall.1" "$pkgdir/usr/share/man/man1/macinstall.1"
+
+}
+
+
+