summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7c6007bfb25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer Cookie Engineer <@cookiengineer>
+
+pkgname=simple-chroot-git
+pkgver=r89.edda14f
+pkgrel=1
+pkgdesc="Simple chroot environment manager"
+arch=(any)
+url=https://github.com/mh5/simple-chroot
+license=( "BSD" )
+depends=('bash')
+options=('!emptydirs')
+source=("git+https://github.com/mh5/simple-chroot.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/simple-chroot"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/simple-chroot"
+ mkdir -p "{$pkgdir}/usr/bin";
+ install -Dm755 "${srcdir}/simple-chroot/simple-chroot.sh" "${pkgdir}/usr/bin/simple-chroot";
+}
+