summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41cfab084949..ea91a67b8a77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=simple-fb2-reader
pkgver=1.1.1
-pkgrel=2
+pkgrel=3
pkgdesc="Simple FB2 book reader on GTK+3"
arch=('i686' 'x86_64')
url="http://github.com/Cactus64k/simple-fb2-reader"
@@ -10,8 +10,14 @@ license=('GPL3')
depends=('libxml2>=2.9.1' 'gtk3>=3.14.5' 'glib2>=2.33.12' 'libzip>=0.10.1' 'sqlite>=3.8.7.1')
makedepends=('gettext>=0.19.3' 'pkg-config>=0.28')
install=$pkgname.install
-source=(http://github.com/Cactus64k/simple-fb2-reader/archive/$pkgver.tar.gz)
-md5sums=('85cdaed7419fed02c314e19cb665d96f')
+source=(http://github.com/Cactus64k/simple-fb2-reader/archive/$pkgver.tar.gz fix-crash.patch)
+md5sums=('85cdaed7419fed02c314e19cb665d96f'
+ 'e79f59cd8bc304ca50a81b3aa42d8047')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i "${srcdir}/fix-crash.patch"
+}
build() {
cd $srcdir/simple-fb2-reader-$pkgver