summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47ae49a4593b..cb54c1c5ff0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,20 @@
pkgname=simple-http-server
pkgver=0.4.6
-pkgrel=1
+pkgrel=2
pkgdesc="Simple http server in Rust"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/TheWaWaR/simple-http-server"
license=('MIT')
-depends=()
+depends=('openssl-1.0')
makedepends=('cargo')
options=()
source=("https://crates.io/api/v1/crates/${pkgname}/${pkgver}/download")
sha384sums=('48afad660d4b780ec360167c99dce03b97290237c21c3973a40fb2d38fa8c49b1d8f59368e448b25568909dbbb9793d8')
build() {
+ export OPENSSL_LIB_DIR="/usr/lib/openssl-1.0"
+ export OPENSSL_INCLUDE_DIR="/usr/include/openssl-1.0"
cd "$srcdir/$pkgname-$pkgver"
cargo build --release
}