summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71e000be2f7c..2e061f5f85c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Samuel Walladge <samuel at swalladge dot id dot au>
-# Maintainer: Kewl <kewl@alto.eu.org>
+# Maintainer: Kewl <echo kewl@blto.eu.org | tr b a>
pkgname=simplenote-electron-bin
_pkgname=simplenote
@@ -9,20 +9,15 @@ pkgdesc="The simplest way to keep notes."
arch=('x86_64')
url="https://github.com/Automattic/simplenote-electron"
license=('GPL2')
-depends=('gcc-libs' 'gconf' 'alsa-lib' 'nss' 'libxtst' 'gtk2' 'libnotify')
+depends=('gcc-libs' 'gconf' 'alsa-lib' 'nss' 'libxtst' 'gtk2')
optdepends=()
provides=('simplenote')
source=("https://github.com/Automattic/simplenote-electron/releases/download/v${pkgver}/Simplenote-linux-${pkgver}.deb")
sha256sums=('461ef7e6eea617d6e33818b59a0235d1f09ff6dab57c24810acf261ecbe244ec')
-
package() {
- cd ${srcdir}
-
- # extract the data part of the deb package
- tar xzfp data.tar.gz -C ${pkgdir}
+ bsdtar -xv -C "${pkgdir}" -f "${srcdir}/data.tar.gz"
- # simlink executable to /usr/bin
mkdir -p ${pkgdir}/usr/bin/
ln -s /usr/share/${_pkgname}/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
}