summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 19 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32916731b712..0faa36fe339b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='simplex-chat-bin'
_pkgname="${pkgname%%-bin}"
pkgver=4.5.3
-pkgrel=1
+pkgrel=2
pkgdesc='A 100% private-by-design chat platform (pre-compiled)'
arch=('x86_64')
_platform='ubuntu-20_04-x86-64'
@@ -18,35 +18,50 @@ source=(
"$_rawurl/docs/SIMPLEX.md"
"$_rawurl/docs/SQL.md"
"$_rawurl/scripts/message_views.sql"
+ 'logo-symbol-dark.svg'
+ 'logo-symbol-light.svg'
+ 'simplex-chat.desktop'
)
license=('AGPL3')
depends=(
'gmp'
+ 'hicolor-icon-theme'
'openssl-1.1'
'zlib'
)
provides=('simplex-chat')
conflicts=('simplex-chat')
+build() {
+ case "${SIMPLEX_ICON:-light}" in
+ light ) _shade='light' ;;
+ dark ) _shade='dark' ;;
+ * ) _shade='light' ;;
+ esac
+
+ cp "logo-symbol-$_shade.svg" "$_pkgname.svg"
+}
+
package() {
cd "$srcdir" || exit 1
install -Dm0755 "$_pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
install -Dm0644 message_views.sql "$pkgdir/usr/share/doc/$_pkgname/message_views.sql"
install -m0644 {PRIVACY,README,CLI,SIMPLEX,SQL}.md "$pkgdir/usr/share/doc/$_pkgname/"
+ install -Dm0644 "$_pkgname.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg"
}
sha256sums=(
'2bdf32935cc6d5228eb5e930fc07e32fd87e2894988f0a1d8e61dd1070f8cdec'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
)
sha512sums=(
'a4249198730398dfee7eae880cf4c6cb4d741cf45c3ca2129396ba466a7b146cf985e06820241ccbac698e1c6cbf09ba1e24d22ba1b4a15a689e9e427da3aaf8'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
)
b2sums=(
'4d1fabf40d84c1926ecab132ef9b040d5767bab20ed21e68d85637d8444884d94b83880140ca8fa8ea5b3708f2c074c0f0fc00217db18b807aaedb1d90386e6c'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
)
# eof