summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c4f7a6bd4dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=sind-git
+pkgrel=1
+pkgver=r21.aeecca0
+provides=(sind)
+pkgdesc='Simple Notification Daemon. Prints freedesktop notifications to stdout'
+url=https://github.com/htylo/simplenotifydaemon
+makedepends=(git)
+source=("${pkgname}::git+https://github.com/htylo/simplenotifydaemon")
+arch=(any)
+options=(!strip)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="$pkgdir/" install
+}