summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0d2839ea442..e754739c96be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
pkgname=singularityviewer-alpha
pkgver=1.8.7.6937
-pkgrel=2
+pkgrel=3
_harfbuzzver=1.3.4-1
+_cairover=1.14.10-1
pkgdesc="An exciting client for Second Life (secondlife) and OpenSim (opensimulator), which combines the look and feel of Viewer 1.23 with the latest and greatest of available technology. (alpha version)"
url="http://www.singularityviewer.org/"
license=('custom')
@@ -26,11 +27,14 @@ provides=("singularityviewer")
source=("http://sourceforge.net/projects/singularityview/files/alphas/SingularityAlpha-x86_64-$pkgver.tar.bz2"
"singularityviewer.desktop"
"singularityviewer.launcher"
- "http://archive.archlinux.org/repos/2016/12/06/extra/os/x86_64/harfbuzz-1.3.4-1-x86_64.pkg.tar.xz")
+ "https://archive.archlinux.org/packages/h/harfbuzz/harfbuzz-${_harfbuzzver}-x86_64.pkg.tar.xz"
+ "https://archive.archlinux.org/packages/c/cairo/cairo-${_cairover}-x86_64.pkg.tar.xz")
+
md5sums=('d52e582343b5f173fa10aef7b5eb5ce1'
'ff7aa34dcd7548e3acdb3c2d44ae6604'
'eb596f5cf7b6f2d0c55c0082fb99a905'
- '0a3e4654c3009d740a6be09e58a2d451')
+ '0a3e4654c3009d740a6be09e58a2d451'
+ 'e6208a823c9acc653b1deb0fcf4014c7')
package() {
cd $srcdir
@@ -72,4 +76,9 @@ sed -i 's|./refresh_desktop_app_entry.sh|#./refresh_desktop_app_entry.sh|' $pkgd
cd $srcdir/usr/lib/
cp *harfbuzz.so* $pkgdir/opt/singularityviewer/lib64/
+# Install cairo binaries
+cd $srcir/usr/lib
+cp *libcairo*.so* $pkgdir/opt/singularityviewer/lib64/
+cp cairo/*cairo*.so* $pkgdir/opt/singularityviewer/lib64/
+
}