summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38061c227c3c..19f365501927 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
-# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Maintainer: hrdl <git@hrdl.eu>
+# Contributor: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
# Contributor: Philipp Kühn <p dot kuehn at posteo dot de>
# Contributor: Krut Patel <kroot.patel@gmail.com>
pkgname=sioyek-git
-pkgver=2.0.0.r103.g5517425
-pkgrel=2
+pkgver=2.0.0.r105.g2cdf61c
+pkgrel=1
epoch=1
pkgdesc="PDF viewer for research papers and technical books."
arch=(x86_64)
license=(GPL3)
url="https://github.com/ahrm/sioyek"
-depends=(qt5-base libmupdf)
-makedepends=(git qt5-3d mujs ) #gumbo-parser openjpeg2 jbig2dec harfbuzz
+depends=(qt5-base libmupdf)
+makedepends=(git qt5-3d mujs)
provides=(sioyek)
conflicts=(sioyek)
-# patch retreived from https://paste.debian.net/plain/1290973 (source: https://aur.archlinux.org/packages/sioyek-git#comment-932428)
source=("git+https://github.com/ahrm/sioyek.git"
- "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/sioyek-mupdf-1.23.0.patch")
+ "sioyek-mupdf-1.23.patch")
sha256sums=('SKIP'
- 'b71f3658803c80bd7a5cf59b38bb80418fd85cec06ee631a14d39736f2bfe39c')
+ '30021646fda45c40af4579067ccb098bff4b2934ff42ace7b02a61fd1c8bc573')
pkgver() {
cd "sioyek"
@@ -28,7 +28,7 @@ pkgver() {
prepare() {
cd "sioyek"
- patch --forward --strip=1 --input="${srcdir}/sioyek-mupdf-1.23.0.patch"
+ patch --forward --strip=1 --input="${srcdir}/sioyek-mupdf-1.23.patch"
sed -i 's/-lmupdf-threads/-lfreetype -lgumbo -ljbig2dec -lopenjp2 -ljpeg/' pdf_viewer_build_config.pro
sed -i '/#define LINUX_STANDARD_PATHS/s/\/\///' pdf_viewer/main.cpp
sed -i 's/-lmupdf-third//' pdf_viewer_build_config.pro