summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94cb6dfb9b2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jose Lopes <josemslopes at gmail dot com>
+pkgname=sipsak-git
+pkgver=r493.976c052
+pkgrel=1
+pkgdesc='A small command line tool for developers and administrators of Session Initiation Protocol (SIP) applications.'
+arch=('x86_64')
+url='https://github.com/nils-ohlmeier/sipsak'
+license=('GPL2')
+groups=('voip')
+depends=('gnutls' 'openssl' 'c-ares')
+makedepends=('git')
+source=("${pkgname}::git+https://github.com/nils-ohlmeier/sipsak.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ autoreconf --install
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: