summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53aadc84aaab..af6453220746 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Original Maintainer: Jameson Pugh <imntreal@gmail.com>
_pkgname=skypeforlinux
-pkgname=$_pkgname-stable-bin
-pkgver=8.74.0.152
+pkgname="$_pkgname-stable-bin"
+pkgver=8.109.0.209
pkgrel=1
pkgdesc="Skype for Linux - Stable/Release Version"
arch=("x86_64")
@@ -13,22 +13,23 @@ depends=("gtk3" "libxss" "alsa-lib" "libxtst" "libsecret" "nss"
"glibc>=2.28-4")
optdepends=("org.freedesktop.secrets: keyring/password support"
"libappindicator-gtk3: systray icon support")
-conflicts=("$_pkgname" "$_pkgname-bin" "$_pkgname-preview-bin"
- "$_pkgname-beta-bin" "skype")
+conflicts=("$_pkgname" "$_pkgname-preview-bin" "skype")
provides=("$_pkgname" "skype")
-install=install.sh
+install="$pkgname-install"
+# We embed the pkgrel in the download file name because skype devs
+# sometimes use the same version number for an update and any previously
+# cached file will otherwise fail against the new checksum.
source=(
-"https://repo.skype.com/rpm/stable/${_pkgname}_${pkgver}-1.x86_64.rpm"
+"${_pkgname}_${pkgver}_${pkgrel}_amd64.deb::https://repo.skype.com/deb/pool/main/s/$_pkgname/${_pkgname}_${pkgver}_amd64.deb"
)
-sha256sums=('1b19fbb55c75815c78e9c20ed29a97c6b11c8b45a2444dd8f1aa51d7ca354039')
+sha256sums=('3e66c37bc63b9767f80762c6e9e9377789247d97603395f72ee6e2b8a437e0fb')
package() {
- cd $pkgdir
- bsdtar -xf $srcdir/${_pkgname}_${pkgver}-1.x86_64.rpm
- rm -rf "$pkgdir/usr/lib/.build-id"
+ tar --no-same-owner -xC "$pkgdir" -f data.tar.gz
install -d "$pkgdir/usr/share/licenses/$pkgname"
mv "$pkgdir/usr/share/$_pkgname/LICENSES.chromium.html" \
- "$pkgdir/usr/share/licenses/$pkgname/"
+ "$pkgdir/usr/share/licenses/$pkgname/"
+ rm -rf "$pkgdir/opt"
}
# vim:set ts=2 sw=2 et: