summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 36 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 305d13b5600e..63cf8c7b2170 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _pkgname=slimjet
pkgname="${_pkgname}-beta-bin"
_appname="flashpeak-${_pkgname}"
pkgver=41.0.0.0
-pkgrel=1
+pkgrel=2
_libffmpegverurl="https://github.com/nwjs-ffmpeg-prebuilt/nwjs-ffmpeg-prebuilt"
_libffmpegver=0.80.0
pkgdesc="Fast, smart and powerful browser based on Blink"
@@ -11,14 +11,42 @@ arch=('x86_64')
url="https://www.slimjet.com"
_downurl="https://www.slimjetbrowser.com"
license=('custom:freeware')
-depends=('libxcb' 'at-spi2-core' 'libxdamage' 'libxcomposite' 'pango' 'gcc-libs' 'libxkbcommon' 'libxrandr' 'alsa-lib' 'sh' 'libxext'\
- 'libcups' 'glib2' 'dbus' 'nspr' 'nss' 'libdrm' 'libxfixes' 'expat' 'glibc' 'libx11' 'mesa' 'cairo')
-optdepends=('kdialog: needed for file dialogs in KDE' 'ttf-liberation: fix fonts for some PDFs')
-conflicts=("${_pkgname}35" "${_pkgname}")
-options=('!emptydirs' '!strip')
-source=("${pkgname%-bin}-${pkgver}_amd64.deb::${_downurl}/beta/${_pkgname}_amd64.deb"
+depends=(
+ 'libxcb'
+ 'at-spi2-core'
+ 'libxdamage'
+ 'libxcomposite'
+ 'pango'
+ 'libxkbcommon'
+ 'libxrandr'
+ 'alsa-lib'
+ 'libxext'
+ 'libcups'
+ 'nspr'
+ 'nss'
+ 'libdrm'
+ 'libxfixes'
+ 'expat'
+ 'libx11'
+ 'mesa'
+ 'cairo'
+)
+optdepends=(
+ 'kdialog: needed for file dialogs in KDE' 'ttf-liberation: fix fonts for some PDFs'
+)
+conflicts=(
+ "${_pkgname}35"
+ "${_pkgname}"
+)
+options=(
+ '!emptydirs'
+ '!strip'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}_amd64.deb::${_downurl}/beta/${_pkgname}_amd64.deb"
"libffmpeg-${_libffmpegver}.zip::${_libffmpegverurl}/releases/download/${_libffmpegver}/${_libffmpegver}-linux-x64.zip"
- "LICENSE.html::${url}/en/webhelp/index.htm")
+ "LICENSE.html::${url}/en/webhelp/index.htm"
+)
sha256sums=('17e42f09137b1884a4509d96d7f99d0226ea3c0be3271364b25fe0731c0c5972'
'8afa2102c5bc6e74ac8e812a78c72fbc6342443d06f42098cf496d8ea81529a9'
'2c9dac1462b349e7c077ea33cdc91ff46563b2ca0457617958772a689b4c8d43')