summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 20 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c7d6b693e6d..ef4fb0466b85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
-# Maintainer: Alexis Janon <kardyne -at- gmail -dot- com>
+# Maintainer: Jeremy Gust <jeremy AT plasticsoup DOT net>
+# Contributor: Alexis Janon <kardyne -at- gmail -dot- com>
# Contributor: Kyle Keen <keenerd@gmail.com>
# Contributor: Zhukov Pavel <gelios@gmail.com>
# Contributor: Christof Musik <christof@senfdax.de>
# Contributor: Falconindy
pkgname=slurm
-pkgver=0.4.3
-pkgrel=1
-pkgdesc="Monitoring traffic statistics in realtime"
-url="https://github.com/mattthias/slurm/wiki"
-license=("GPL")
-arch=('i686' 'x86_64')
+pkgver=0.4.4
+pkgrel=2
+pkgdesc="yet another network load monitor"
+url="https://github.com/mattthias/slurm"
+license=("GPL-2.0-or-later")
+arch=('x86_64')
depends=('ncurses')
-makedepends=('cmake')
-source=("https://github.com/mattthias/$pkgname/archive/upstream/$pkgver.tar.gz")
-md5sums=('ff39b8e1fd31274ba1bb36d4aadc1d48')
+makedepends=('meson')
+conflicts=('slurm-llnl') #both packages have manpage "slurm.1"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/upstream/$pkgver.tar.gz")
+sha256sums=('2f846c9aa16f86cc0d3832c5cd1122b9d322a189f9e6acf8e9646dee12f9ac02')
build() {
- cd "$srcdir/$pkgname-upstream-$pkgver"
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ # Sets CFLAGS to the makepkg.conf default (as of 2023-9-9) without "-fexceptions"
+ # as it causes a segfault when slurm is run.
+ CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt \
+ -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security \
+ -fstack-clash-protection -fcf-protection"
+ arch-meson $pkgname-upstream-$pkgver build
+ meson compile -C build
}
package() {
- cd "$srcdir/$pkgname-upstream-$pkgver/build"
- make DESTDIR="$pkgdir" install
- install -Dm644 ../slurm.1 "$pkgdir/usr/share/man/man1/slurm.1"
+ meson install -C build --destdir "${pkgdir}"
}