summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 29 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ef1a4163c90..4949a2c5fdf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,41 @@
+# Maintainer: Aquarius <aquarius24 AT yandex DOT ru>
# Maintainer: AudioLinux <audiolinux AT fastmail DOT fm>
# Contributor: Cvetoslav Ludmiloff <ludmiloff@gmail.com>
-pkgname=smokegen-git
-pkgver=20150630
+_name=smokegen
+
+pkgname=$_name-git
+pkgver=4.14.3
pkgrel=1
-pkgdesc="A general purpose C++ parser with a plugin infrastructure"
-url="http://kde.org/"
+pkgdesc="A general purpose C++ parser with a plugin infrastructure. It is currently used for generating the various SMOKE libraries"
arch=('i686' 'x86_64')
-license=('GPL' 'LGPL' 'FDL')
-depends=('')
-makedepends=('cmake' 'automoc4' 'git')
-conflicts=('kdebindings-smokegen')
+url=""
+license=('GPL')
+groups=()
+depends=('qt4')
+makedepends=('git' 'cmake')
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("git+https://github.com/KDE/smokegen.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_name"
+
+# Git, tags available
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
-_gitroot="git://anongit.kde.org/smokegen"
-_gitname="smokegen"
build() {
- cd "${srcdir}"
- msg "Connecting to GIT server"
-
- if [ -d $_gitname ]; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitname
- cd "${_gitname}"
- fi
-
- if [ ! -d build ]; then
- mkdir build
- fi
-
- cd build
- cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
-
- numprocs=`cat /proc/cpuinfo | grep processor | wc -l`
- make -j `expr ${numprocs} + 1`
+ mkdir "$srcdir/$_name/build"
+ cd "$srcdir/$_name/build"
+ cmake ../
+ make
}
package() {
- cd "${_gitname}"/build
- pwd
- make DESTDIR="${pkgdir}" install
+ cd "$srcdir/$_name/build"
+ make DESTDIR="$pkgdir/" install
}