summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eaa46965c2af..7e255d01a06f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,22 @@
# Maintainer: Michael Picht <michael dot picht at ussenterprise dot de>
-pkgorg=gitlab.com/mipimipi
+_pkgorg=gitlab.com/mipimipi
pkgname=smsync-git
_pkgname=smsync
-pkgver=3.4.0
+pkgver=3.4.0.r1.gc34ff52
pkgrel=1
pkgdesc="smsync (Smart Music Sync) keeps huge music collections in sync and is takes care of conversions between different file formats. It's an easy-to-use command line application for Linux"
arch=('x86_64' 'i686')
-url="https://$pkgorg/$_pkgname/"
+url="https://$_pkgorg/$_pkgname/"
license=('GPL3')
depends=('ffmpeg')
-makedepends=('go-pie' 'dep')
-source=("git://$pkgorg/$_pkgname.git")
+makedepends=(
+ dep
+ git
+ go-pie
+)
+source=("git+https://$_pkgorg/$_pkgname.git")
sha256sums=('SKIP')
pkgver() {
@@ -24,21 +28,21 @@ pkgver() {
}
prepare() {
- mkdir -p gopath/src/$pkgorg
- ln -rTsf $_pkgname gopath/src/$pkgorg/$_pkgname
+ mkdir -p gopath/src/$_pkgorg
+ ln -rTsf $_pkgname gopath/src/$_pkgorg/$_pkgname
export GOPATH="$srcdir"/gopath
- cd gopath/src/$pkgorg/$_pkgname
+ cd gopath/src/$_pkgorg/$_pkgname
dep ensure
}
build() {
export GOPATH="$srcdir"/gopath
- cd gopath/src/$pkgorg/$_pkgname
+ cd gopath/src/$_pkgorg/$_pkgname
make VERSION=$pkgver
}
package() {
export GOPATH="$srcdir"/gopath
- cd gopath/src/$pkgorg/$_pkgname
+ cd gopath/src/$_pkgorg/$_pkgname
make DESTDIR="$pkgdir" install
}